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Analyzing Data Using AccessAnalyzing Data Using AccessAnalyzing Data Using AccessAnalyzing Data Using Access    

Databases are collections of data organized into forms and tables for easy 
access, management, and querying. Educators use databases every day to check 
accounting records, post student grades, access security systems, and register 
for seminars. Even your list of personal contacts and your computer financial 
program use databases. 

Microsoft® Access® allows you to harness the power of a database to enable more 
effective use of data. Whether you are recording grades for your students, 
tracking attendance, doing research, or evaluating survey data, you can make 
more sense of the information by analyzing it within a database application. 

In this hands-on session, you will learn to create simple databases and Web 
interfaces to view the contents of a database. You will also learn to import data 
from a variety of sources, such as text files from Web-based surveys, and then 
analyze it. This session will prepare you to work with data you collect from 
quizzes, tests, and surveys that you can create in Microsoft® FrontPage®. 

Before You BeginBefore You BeginBefore You BeginBefore You Begin    

Access is a relational database management program. It allows users to create 
storage structures for data, to manipulate and analyze that data, and to format 
the data for output in printed reports or on the Web. It also integrates nicely with 
FrontPage 2000 to provide the data collection mechanism for data enabled Web 
pages. 

 

What you will 
do: 
 

� Use Web 
Templates  
 

� Import data 
from text 
files 
 

� Ask 
questions of 
your data 
using 
queries 
 

� Understand 
cross-tab 
queries 
 

� Create a 
report  
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Touring AccessTouring AccessTouring AccessTouring Access    

Before you start working with collected data, become familiar with the 
features of Access. The following illustration shows the Database 
Container:  

 

 

Words to know: 
 
Table————A storage 
structure for data that is 
composed of like 
columns of information 
(fields) and repeated in 
rows (records). Similar to 
a single worksheet in 
Excel. 
 
Query———— A question 
asked of the data 
contained in tables or 
other queries , for 
example,, “Which 
students passed the 
final?” 
 
Form————A screen used to 
format the output of a 
query or table for display 
or to allow for data entry. 
 
Report—Formatted 
output of data for 
printing; receives data 
from tables and queries. 
 
Field—A column of data 
in a table (e.g. Last 
Name in a table of 
names and addresses). 
 
Primary Key—The field 
on which a table can be 
related to another table 
to join the two together 
(e.g. your account 
number at your bank ties 
you to a table of 
transactions, loans,  and 
personal data). 
 
Cross-tab Report—
Rotation of data to allow 
a more organized view of 
the information. Creates 
a spreadsheet like view 
of data. 
 
Microsoft® Access 
2000—The latest version 
of Microsoft’s desktop 
relational database 
management 
application. Allows 
simple database 
manipulation as well as 
full turnkey application 
creation. Seamless 
integration with the 
Microsoft Office family of 

applications. 
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Using DatabasesUsing DatabasesUsing DatabasesUsing Databases    

You have collected data in your Access database from a Web-based 
survey and now you want to tabulate the results. You have also given a 
quiz and you want to summarize the grades which are contained in a 
text file and then enter them into your grade book. You will need to 
create a database that will import the students’ answers so that you 
can manipulate the data and create the reports. 

To effectively use Access, it is important to understand the role of a 
database. A database is a collection of tables, queries, forms, reports, 
and program codes that make it easy to organize the interrelations of 
these objects. Tables are the containers for data that is arranged into 
rows (records) and columns (fields). Queries are questions that are 
asked of your data (for example, how many students failed the quiz). 
Forms are screens that are used to present or collect data in an 
organized manner (for example, the data entry screen that the 
registrars office completes for a new student). Reports format the 
output for printing (for example, a class schedule posted on a bulletin 
board). Macros and Modules are user programs that are written to 
automate functions or to create a complete database application. 
Access databases are relational databases, which means that they 
contain several tables that are linked together by special matching 
fields called primary keys. Complex data structures can be stored and 
accessed in the most efficient way possible. The term relational is 
derived from the fact that the tables are related to each other. If you 
want to examine Access databases further than this workshop permits, 
Microsoft has a series of step-by-step books and other reference 
material available. Just point your browser to 
http://mspress.microsoft.com and search for Access to find relevant 
titles and a brief synopsis of each. 
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Creating a DatabaseCreating a DatabaseCreating a DatabaseCreating a Database    

This section describes how to quickly create a database to store and 
analyze data. Databases can be very simple (like the one you will 
create) to very complex (like the one the IRS uses to keep track of tax 
records). Whole courses of study can be derived from the design and 
implementation of data stores. The files you will create are a 
foundation for your use of data and are meant to be a useful tool in 
your work. You will not be a database guru nor have a full-featured 
database when you complete this workshop, but you will have a good 
understanding of how to create a simple database and the extensibility 
of these tools. 

The following illustration shows the dialog box that is presented to 
create a new database file: 

 

To create a new databaseTo create a new databaseTo create a new databaseTo create a new database    

1. Start Access. On the File menu, click New. 

2. Select Database from the General tab and then click OK. 

3. Choose a filename and location and then click Create. Your 
new database will be opened in the Database    Container. 

 
The sample files that 
come with Access 
are an excellent 
reference tool for 
developing more 
complex databases. 
Not only do you see 
the functionality that 
can be built into a 
database, but also 
you are given the 
features behind that 
functionality. 
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Importing DataImporting DataImporting DataImporting Data    

Data can exist in many different formats and repositories. 
Incorporating external data into a database is an essential time saving 
task. There is no need to rekey existing electronically stored data, you 
can just import it. Of course, Access can’t possibly read all of the 
different types of data formats that exist, but you can save data as a 
delimited text file in most applications. Delimited indicates that each 
section of data is separated or defined by some sort of special 
character. For example, the comma, the quote, and the space are very 
common delimiters. The data can then be interpreted from this file and 
imported into Access. This same method can be used to extract data 
from Access and into other database systems. You are going to import 
the results of a Web-based survey and then analyze the data to 
summarize the results. 

To import a delimited text fileTo import a delimited text fileTo import a delimited text fileTo import a delimited text file    

1. Click Get External Data from the File menu and then click 
Import. 

2. Select Text Files in the Files of type drop down list and 
navigate to the file you want to import (results.txt for the 
lab). 

3. Double-click the file.  
-or- 
Click once on the file and then click Import. 

4. The Import    Text    Wizard opens. Click Next to accept a 
delimited text file. 

5. Select the First Row Contains Field Names and then click 
Next. The data will be shown in the window. 

 
Some file formats 
can be linked into 
Access, which leaves 
the data in its native 
format. Dbase and 
Excel data can be 
accessed in this way. 
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6. Click Next, indicating that you want to store your data in a 
new table. 

7. Click Next to accept the field settings. 

8. Select No primary key and then click Next. 

9. Change the name of the table if you want and then click 
Finish. (Results will be fine for the lab.) 

10. Respond OK to the information box that notifies you that the 
import completed successfully. 

You now have a new table listed in the Database Container that 
is named by your selection in step 9. (Any additional imports will 
be similar to this one.) 

Using QueriesUsing QueriesUsing QueriesUsing Queries    

Queries allow you to ask questions of your data. The answer is called a 
dynaset. Dynaset is a term that describes the set of records that the 
query returns in response to the question asked of the data. The 
questions allow the distillation of a large quantity of data into easy to 
understand statements. A query of student test scores can show the 
students who correctly answered questions 2 and 10, or the number of 
students with perfect attendance. 
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To create a simple queryTo create a simple queryTo create a simple queryTo create a simple query    

1. Select Queries from the Objects list and then click New on 
the Database Container toolbar. 

2. Click Simple Query Wizard and then click OK. 

 

3. Select the fields you want to be included in the query and 
click the >>>> button. 

4. Click Next to move to the next screen, and then click Next a 
second time to produce a detail query. 

5. Click Finish to display the completed query. 
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To get specific with criteriaTo get specific with criteriaTo get specific with criteriaTo get specific with criteria    

1. After creating the query above, change to Design view by 
clicking Design View from the View menu. 
-or- 
Click Design View on the toolbar. 

 

2. Click the criteria line in the age column and type >45. 

3. Change to Datasheet view by clicking Datasheet View from 
the View menu. 
-or- 
Click Datasheet View on the toolbar. 

4. You will see the results of your query. Notice that all the 
ages of the survey respondents are greater than 45. 

5. Change back to Design view to revise your query. 

6. Save your query by clicking Save As from the File menu and 
then type a name in the space provided. 

You can change the criteria in any of the columns of data by 
using the same steps. Think of the criteria as a statement that 
says “Where age (column) is equal to (operator) 50 (value).” In 
Structured Query Language (SQL) this is called the WHERE 
clause. Each criteria box you fill-in narrows down the list of 



Analyzing Data Using Access 
 

10  

records that will be returned by the query. Valid operators are 
In, Between, =, >, < or combinations of these commands. 
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To create a crosstab queryTo create a crosstab queryTo create a crosstab queryTo create a crosstab query    

1. Select Queries from the Objects list and then click New on 
the Database Container toolbar. 

2. Click Crosstab Query Wizard and then click OK. 

3. Click Next, indicating that you want to base your query on 
the results table. 

4. Double-click scope to select its contents as the row 
headings and then click Next. 

5. Double-click industry to select its contents as the column 
headings. 

6. Click Next to accept ID as the values for your cross-tab and 
to have a totals column. 

7. Select Modify the design and then click Finish to accept 
the default name Results_Crosstab. 
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8. Change the Total row under the last two columns from 
Expression    to Count. This action makes the query fill the 
area of the spreadsheet with the numbers of occurrences at 
each location in the value section rather than try to evaluate 
an invalid expression. The most commonly used Total row 
selections are count and sum. 

9. Change to Datasheet view by clicking Datasheet View from 
the View menu. 
-or- 
Click Datasheet View on the toolbar. 

10. Save your query by selecting Save from the File menu. 
-or- 
Click Save on the toolbar. 

When you view the output of a cross-tab query you can see that 
it creates a spreadsheet that contains the data you requested. 
Each unique item in the field chosen for row heading appears 
as a row heading and each unique item chosen for column 
heading appears as a column heading. The field chosen for the 
value is manipulated based on the total row setting and the 
values are displayed at each row/column intersection. This type 
of analysis is very useful for finding distributions. For example, if 
you have a table of student grades, a cross-tab query of the 
data will show the grade distribution and the average for each 
student and each graded item. 

Using ReportsUsing ReportsUsing ReportsUsing Reports    

Now that you have tables and queries, you can format them for output 
to a printer. Reports allow you to customize the look of the data 
contained in a table or query. The data can be grouped, sorted, and 
manipulated to present the data in the most useful way for those who 
will be reviewing it. 
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To create a reportTo create a reportTo create a reportTo create a report    

1. Select Reports from the Objects list and then click New on 
the Database Container toolbar. 

2. Select Report Wizard and then, in the box at the bottom of 
the dialog box, select the table or query that will be 
providing the data. (Select Results for the lab.) 

3. Click OK to start the wizard. 

 

4. Select age, scope, industry, prepared, hardware, os, 
enduser, and applications, and then click Next. 

5. Double-click age and then click Grouping Options. 

6. Under Grouping Options select 10s and then click OK. 

7. Click Next and select a field to sort by. (Select scope for the 
lab.) 

8. Click Next and choose the Layout and Orientation. (You can 
preview the affect of each by looking in the Preview window 
on the left.) 

    
Use wizards to 
create the basic 
queries, forms, and 
reports. Examine 
these to develop 
your knowledge of 
these objects as they 
are a great stepping 
stone to a full 
understanding of 
these major Access 
components. 
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9. Click Next and select a StStStStylelelele for your report. Click Next. 

10. Type a title and then click Finish. Your report will open in 
Print Preview, which will allow you to examine the proposed 
output before it is printed. 

11. Save your report by clicking Save As from the File menu. 
Type the name you want, and then click OK. 

You can create a report from any query or table. To create a 
cross-tab report, select the appropriate cross-tab query in step 
2. 

Using Web PagesUsing Web PagesUsing Web PagesUsing Web Pages    

In addition to making your data available to others by printing out 
reports, you can also create Web pages that display the contents of 
queries and reports. This will allow anyone with a browser to view your 
data in an organized manner. 

To create data access pagesTo create data access pagesTo create data access pagesTo create data access pages    

1. Select Pages from the Objects list and then click New on 
the Database Container toolbar. 

2. Select Page    Wizard and then click OK. 

3. Select the appropriate table or query. (Select 
Results_Crosstab for the lab.) 

4. Click the double greater than symbol to select all fields and 
then click Next. 

5. Click Next to continue past the screen that allows the 
grouping of records. 

6. Click Next to continue past the sorting selection. 
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7. Enter an appropriate name for your page and then click 
Finish. 

 

8. Click Page View from the View menu to see the page as it 
will look in a browser. 

Notice the navigation bar at the bottom of the data. It allows 
you to move quickly and easily through the records that are 
being displayed. You can also construct your own page from 
scratch but that will require knowledge of controls. Controls are 
the items that can be placed on a form to display contents of 
queries and tables, display graphics and text, and interact with 
the user. This is a more advanced topic outside the scope of 
this workshop, but there are plenty of reference materials on 
the subject. 



Analyzing Data Using Access 
 

16  

Getting HelpGetting HelpGetting HelpGetting Help    

You can get help from the Office Assistant or the online Help at any 
time while you are using Access. To open the Office Assistant, click 
Access Help on the Standard toolbar. To open the online Help, on the 
Help menu click Microsoft Access Help. If you have an Internet 
connection, you can also point to Office on the Web on the Help menu 
and choose from several resources that may be of interest to you such 
as Product News, Frequently Asked Questions, and    Online Support. 
You can also go to www.microsoft.com/access for all of the latest 
information. 

 

 

 

 

 

 

 

Information in this document, including URL and other Internet Web 
site references, is subject to change without notice. Companies, 
names and data used in examples herein are fictitious unless 
otherwise noted. 

© 1999 Microsoft Corporation. All rights reserved. 

Microsoft Corporation retains sole ownership of all published In and 
Out of the Classroom materials. Microsoft grants permission for 
educational institutions and Microsoft OEMS and Solution Partners to 
reproduce these materials for staff development purposes (only). 
Altering materials or reselling materials is strictly prohibited. 

Microsoft, BackOffice, FrontPage, Microsoft Internet Explorer, and the 
Microsoft Internet Explorer logo, the Microsoft Office logo, NetMeeting, 
Outlook, PowerPoint, Where do you want to go today?, Windows NT, 
Windows, the Windows logo, and the Windows Start logo are either 
registered trademarks or trademarks of Microsoft Corporation in the 
United States and/or other countries. 



Analyzing Data Using Access 
 

17 

Other product and company names mentioned herein may be the 
trademarks of their respective owners. 

AcknowledgmentsAcknowledgmentsAcknowledgmentsAcknowledgments    

This workshop was created in partnership with Scott Sample and S&T 
Consulting, an    information design and development firm: 
www.sakson.com 
 
S&T Consulting project team: Sara Bosarge, Blake W. Bratt, Beth 
Harmon, Carolyn Emory, Amy Krzysiek, and Tonya Stumphauzer. 


